PHPCGI - latest versions 4.4.6 and 5.2.1

 
Post new topic   Reply to topic    34SP.com Forum Index // Scripting Support
View previous topic :: View next topic  
Author Message
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Thu Nov 03, 2005 9:34 pm    Post subject: PHPCGI - latest versions 4.4.6 and 5.2.1 Reply with quote
Many users are using our php.cgi that we have compiled for various tasks that have issues under the normal mod_php4.

(At this time this only applies to php4 cgi users - i understand that a update is in progress on php5 but has not at this time the source has not been fully released other than in the development CVS)

Due to some recent issues found in php, the php.cgi has been recompiled, as such we recommend where possible that you upgrade the php.cgi that you are using.

First before doing this check the php outputs at http://support.34sp.com/phpcgi and ensure that all the modules are present that you are using as many people have had custom cgi's built with the odd extra.

Please note that despite showing "sqlite" in the configure command this is not at this time compiled into the cgi ( depending on demand this will be re-added in the future )., so if you use php.cgi and sqlite at this time DO NOT upgrade using the method below.

We have now introduced a semi-automated installer for the php.cgi onto the shared hosting accounts.

First - just incase you do find issues with the new php.cgi - i recommend via your ftp client that you rename the current php.cgi to php.cgi.old (or similar) that way its easy to revert if you find any issues. (remember to delete it once you are happy as you will be using excess diskspace with it)

If you open up notepad (or similar) and save yourself a blank file named "php4.cgi" and then simply upload this to your cgi-bin folder, within seconds this will automatically be updated to the new php.cgi file for you.

You will then be able to test the new php.cgi is working by visiting http://YOURDOMAIN/testphpcgi in your browser and you should get a similar output to the link listed above.

Again you can remove this directory with your ftp client if all is working well to reclaim the disk space used by it.

If you have any issues with this - or you do find that you had a custom module compiled into a php.cgi for yourself then please do email us and we will reproduce a new compile for your site.

In regards to the normal php installation, plesk support has been contacted and they are looking into producing an upgraded version for the main php, whether this will be as a hotfix or a new upgrade at this time they dont know. We will if its a hotfix get this updated as soon as possible for people.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |


Last edited by imknight on Fri Mar 30, 2007 1:18 pm; edited 6 times in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Mon Jan 16, 2006 5:35 pm    Post subject: Reply with quote
The PHPCGI version 4 has now been updated to PHP4.4.2, the compile should be the same as before, however sqlite has now been added to the standard install instead of the nead for a customized version if you used this in the past.

Please follow the instructions in the previous post to upgrade your current phpcgi - but if you have issues do email us, we are aware that the auto installer does not work in all circumstances.

phpinfo output of php4.4.2 at http://phpcgi.34sp.com/php4cgi/
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Thu Feb 16, 2006 3:34 pm    Post subject: Reply with quote
A new easier to use installer is now available at

https://phpcgi.34sp.com/install/

Please note this is for full domains only - it will not work 100% on subdomains that you set up via the siteadmin interface.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Fri May 05, 2006 3:19 pm    Post subject: Reply with quote
The php5cgi binaries have been updated now to the latest version of php 5.1.4 that was released yesterday.

If you are using the standard php5cgi installs please simply go through the installer again to re-install the newer version - use the /testphpcgi/ link to confirm the upgrade has goine ok.

Any issues please let us know.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Mon Aug 21, 2006 5:03 pm    Post subject: Reply with quote
The php4cgi compiles have now been updated to the latest php4.4.4.

We will be updating the php5 compiles over the next few days.

If you wish to use the newer version of phpcgi - simply go through the installer again and it will replace your current version.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Tue Aug 22, 2006 12:04 pm    Post subject: Reply with quote
php5cgi has now been updated to PHP5.1.5
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Wed Jan 10, 2007 12:34 pm    Post subject: Reply with quote
The phpcgi installer has had a bit of an overhaul.

Firstly the php version has been brought up to current so is now at version 5.2.0.

There has also been the addition of subdomain support - as long as the subdomain has its own ftp account - the installer will now install correctly on the subdomain without any need to mail us for minor changes to it.

And an advanced section has been added with a few common variables that we have been asked to change regularly. For the upmost of installs you wlil not need to touch these.

The installer has also moved to our http://script.34sp.com installer system but can be accessed easily via http://phpcgi-install.34sp.com or any of the old links which have also been updated.

Any issues found with this new installer please do let us know.

Thanks.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
imknight
Administrator
Administrator


Joined: 16 Mar 2001
Posts: 3627
Location: Stroud,Gloucestershire

PostPosted: Fri Mar 30, 2007 1:22 pm    Post subject: Reply with quote
There has now been another update to the phpcgi installers.

The versions of PHP have been updated to 4.4.6 and 5.2.1.

There is also the addition of a "Minimal" install, this is a compacted binary with very few extras but does include mysql and gd which are generally the most common needed additional modules.

If your script allows, the using of the smaller binaries is beneficial as it will be faster than when using the larger binaries.

We have tested gallery2 on a minimal php installation and that appears to work fine.

Any issues with the installer please let us know.
_________________
Ian
34SP.com
Easy script installers for a small number of popular scripts are now available at http://scripts.34sp.com
Used our script installers? Please post your site here

| Wordpress Hosting |
Back to top
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
Post new topic   Reply to topic    34SP.com Forum Index // Scripting Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Powered by phpBB © 2001, 2002 phpBB Group