linux help, configuring ssmtp

 
Post new topic   Reply to topic    34SP.com Forum Index // Email Support
View previous topic :: View next topic  
Author Message
apacheuk
34SP Newbie
34SP Newbie


Joined: 20 Mar 2012
Posts: 12

PostPosted: Fri Jul 13, 2012 2:51 pm    Post subject: linux help, configuring ssmtp Reply with quote
Hi,

I'm trying to configure ssmtp (yes I know its not a spelling mistake) to send email via my domains smtp server from the command line.

I have it configured like so

Code:

#
# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=deny@sibass.co.uk

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.sibass.co.uk:25

# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
hostname=sibass.co.uk

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
AuthUser = XXXXXXXXXXXX
AuthPass = XXXXXXXXXXXX
AuthMethod=LOGIN
FromLineOverride=YES


which looks OK and I've used this method before, however I get the following error message

Quote:

ssmtp: Authorization failed (535 Incorrect authentication data)


I'm stumped, I know the username and password I'm using are correct as I can successfully send and receive mail using a mail client using the same details

Cheers
Simon
Back to top
View user's profile Send private message
apacheuk
34SP Newbie
34SP Newbie


Joined: 20 Mar 2012
Posts: 12

PostPosted: Fri Jul 13, 2012 8:32 pm    Post subject: Reply with quote
little more info.... this is a copy of the log produced when I try to send the email

Code:

[<-] 220 smtpauth2.smtp1.array.34sp.com ESMTP Exim 4.72 Fri, 13 Jul 2012 21:29:56 +0100
[->] HELO sibass.co.uk
[<-] 250 smtpauth2.smtp1.array.34sp.com Hello host109-152-92-178.range109-152.btcentralplus.com [109.152.92.178]
[->] MAIL FROM:<xxxx@sibass.co.uk>
[<-] 250 OK
[->] RCPT TO:<xxxxxxxx.simon@btinternet.com>
[<-] 550 relay not permitted


which is the same output I get when I telnet onto the smtp server and try to send an email that way.

Is there some setting I need to enable in order to be able to do this?

Cheers
Simon
Back to top
View user's profile Send private message
apacheuk
34SP Newbie
34SP Newbie


Joined: 20 Mar 2012
Posts: 12

PostPosted: Sun Aug 19, 2012 11:36 am    Post subject: Reply with quote
still can't get this to work properly.

I know my mail/smtp server is working correctly as I can send and receive email using my email client - Evolution

I'm at a loss, I'm thinking this must be a server setting or something
Back to top
View user's profile Send private message
apacheuk
34SP Newbie
34SP Newbie


Joined: 20 Mar 2012
Posts: 12

PostPosted: Sun Aug 19, 2012 2:25 pm    Post subject: Reply with quote
finally figured it out, seems in the configuration file you can't have a space after the '=' sign... one of my settings had a space after the '=' and the login name

never mind, all working now
Back to top
View user's profile Send private message
Post new topic   Reply to topic    34SP.com Forum Index // Email Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Powered by phpBB © 2001, 2002 phpBB Group